<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://timesdelphic.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<meta property="og:type" content="article">
<meta property="og:title" content="Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators">
<meta property="og:site_name" content="The Times-Delphic">
<meta property="og:description" content="Update: Graciela Breton-Solano says she has won the Equity and Inclusion senator position through UNITY, Areli Herrera has decided to">
<meta property="og:url" content="https://timesdelphic.com/2022/04/2022-student-senate-candidates/">
<meta property="og:locale" content="en_US">
<meta property="article:published_time" content="2022-04-11T23:47:41+00:00">
<meta property="article:modified_time" content="2022-04-13T18:19:04+00:00">
<meta property="article:section" content="Top News">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators">
<meta name="twitter:description" content="Update: Graciela Breton-Solano says she has won the Equity and Inclusion senator position through UNITY, Areli Herrera has decided to">
<meta name="twitter:url" content="https://timesdelphic.com/2022/04/2022-student-senate-candidates/">
<meta name="twitter:site" content="">
			<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
			
	<!-- This site is optimized with the Yoast SEO plugin v18.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators - The Times-Delphic</title>
	<link rel="canonical" href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators - The Times-Delphic" />
	<meta property="og:description" content="Update: Graciela Breton-Solano says she has won the Equity and Inclusion senator position through UNITY, Areli Herrera has decided to withdraw from the race for Equity and Inclusion Senator and Michael Mitchell has emailed the election commission to withdraw from the SJMC Senator race. Campaigning has begun for the general election for the 2022-2023 Drake [&hellip;]" />
	<meta property="og:url" content="https://timesdelphic.com/2022/04/2022-student-senate-candidates/" />
	<meta property="og:site_name" content="The Times-Delphic" />
	<meta property="article:published_time" content="2022-04-11T23:47:41+00:00" />
	<meta property="article:modified_time" content="2022-04-13T18:19:04+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Andrew Kennard" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://timesdelphic.com/#website","url":"https://timesdelphic.com/","name":"The Times-Delphic","description":"Drake University&#039;s student newspaper established in 1884. Hailing from Drake University in Des Moines, this paper brings you hard-hitting and important news.","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://timesdelphic.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://timesdelphic.com/2022/04/2022-student-senate-candidates/#webpage","url":"https://timesdelphic.com/2022/04/2022-student-senate-candidates/","name":"Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators - The Times-Delphic","isPartOf":{"@id":"https://timesdelphic.com/#website"},"datePublished":"2022-04-11T23:47:41+00:00","dateModified":"2022-04-13T18:19:04+00:00","author":{"@id":"https://timesdelphic.com/#/schema/person/16fe10de368722676082021f02d4d080"},"breadcrumb":{"@id":"https://timesdelphic.com/2022/04/2022-student-senate-candidates/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://timesdelphic.com/2022/04/2022-student-senate-candidates/"]}]},{"@type":"BreadcrumbList","@id":"https://timesdelphic.com/2022/04/2022-student-senate-candidates/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators"}]},{"@type":"Person","@id":"https://timesdelphic.com/#/schema/person/16fe10de368722676082021f02d4d080","name":"Andrew Kennard","url":"https://timesdelphic.com/author/andrew-kennard/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Times-Delphic &raquo; Feed" href="https://timesdelphic.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Times-Delphic &raquo; Comments Feed" href="https://timesdelphic.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Times-Delphic &raquo; Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators Comments Feed" href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.5.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-88365498-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/timesdelphic.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			<style type="text/css">
		</style>
		<link rel='stylesheet' id='wp-block-library-css'  href='https://timesdelphic.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='liveblog24_live_blogging_tool-cgb-style-css-css'  href='https://timesdelphic.com/wp-content/plugins/24liveblog/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='azc-tsh-css'  href='https://timesdelphic.com/wp-content/plugins/azurecurve-toggle-showhide/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://timesdelphic.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-font-css'  href='https://timesdelphic.com/wp-content/plugins/ditty-news-ticker/inc/static/libs/fontastic/styles.css?ver=2.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='ditty-news-ticker-css'  href='https://timesdelphic.com/wp-content/plugins/ditty-news-ticker/inc/static/css/style.css?ver=1613713087' type='text/css' media='all' />
<link rel='stylesheet' id='fts-feeds-css'  href='https://timesdelphic.com/wp-content/plugins/feed-them-social/feeds/css/styles.css?ver=2.9.3' type='text/css' media='' />
<link rel='stylesheet' id='flytedesk-digital-css'  href='https://timesdelphic.com/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-video-css'  href='https://timesdelphic.com/wp-content/plugins/jnews-video/assets/css/plugin.css?ver=7.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-video-darkmode-css'  href='https://timesdelphic.com/wp-content/plugins/jnews-video/assets/css/darkmode.css?ver=7.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='woocs-slider-css-css'  href='https://timesdelphic.com/wp-content/plugins/woocommerce-category-slider/styles/jquery.bxslider.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='woocs-main-css-css'  href='https://timesdelphic.com/wp-content/plugins/woocommerce-category-slider/styles/main.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='ai-core-style-css'  href='https://timesdelphic.com/wp-content/plugins/aesop-story-engine/public/assets/css/ai-core.css?ver=1' type='text/css' media='all' />
<style id='ai-core-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='ai-lightbox-style-css'  href='https://timesdelphic.com/wp-content/plugins/aesop-story-engine/public/assets/css/lightbox.css?ver=1' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='jeg_customizer_font-css'  href='//fonts.googleapis.com/css?family=Work+Sans%3Aregular%2C600%7CLibre+Baskerville%3Aregular%2Citalic%2C700&#038;display=swap&#038;ver=1.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpgform-css-css'  href='https://timesdelphic.com/wp-content/plugins/wpgform/css/wpgform.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://timesdelphic.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://timesdelphic.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='https://timesdelphic.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=7.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-elementor-css'  href='https://timesdelphic.com/wp-content/themes/jnews/assets/css/elementor-frontend.css?ver=7.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://timesdelphic.com/wp-content/themes/jnews/style.css?ver=7.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://timesdelphic.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=7.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-scheme-css'  href='https://timesdelphic.com/wp-content/themes/jnews/data/import/newspaper/scheme.css?ver=7.0.4' type='text/css' media='all' />
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.5.0' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/timesdelphic.com","hash_tracking":"false","ua":"UA-88365498-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/azurecurve-toggle-showhide/jquery.js?ver=3.9.1' id='azc-tsh-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/feed-them-social/feeds/js/powered-by.js?ver=2.9.3' id='fts_powered_by_js-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/feed-them-social/feeds/js/fts-global.js?ver=2.9.3' id='fts-global-js'></script>
<script type='text/javascript' id='flytedesk-digital-js-extra'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8310c8-ffbf-4efd-bb4e-2f1c840c2afb"};
/* ]]> */
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101' id='flytedesk-digital-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/woocommerce-category-slider/js/jquery.bxslider.min.js?ver=5.8.4' id='woocs-slider-js-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/woocommerce-category-slider/js/main.js?ver=5.8.4' id='woocs-main-js-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/multi-level-navigation-plugin/scripts/superfish.js?ver=1.4.8' id='superfish-js'></script>
<link rel="https://api.w.org/" href="https://timesdelphic.com/wp-json/" /><link rel="alternate" type="application/json" href="https://timesdelphic.com/wp-json/wp/v2/posts/34193" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://timesdelphic.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://timesdelphic.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://timesdelphic.com/?p=34193' />
<link rel="alternate" type="application/json+oembed" href="https://timesdelphic.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftimesdelphic.com%2F2022%2F04%2F2022-student-senate-candidates%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://timesdelphic.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftimesdelphic.com%2F2022%2F04%2F2022-student-senate-candidates%2F&#038;format=xml" />
<script data-ad-client="ca-pub-3896753490491021" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<script> id="mcjs">!function(c,h,i,m,p){m=c.createElement(h),p=c.getElementsByTagName(h)[0],m.async=1,m.src=i,p.parentNode.insertBefore(m,p)}(document,"script","https://chimpstatic.com/mcjs-connected/js/users/a74f5e98250c645c05bc0008b/8224bfead97ba6a1e69e33da0.js");</script>
<!-- Multi-level Navigation Plugin v2.3.6 by Ryan Hellyer ... https://geek.hellyer.kiwi/multi-level-navigation/ -->
<!--[if lte IE 7]><script type="text/javascript" src="https://timesdelphic.com/wp-content/plugins/multi-level-navigation-plugin/scripts/suckerfish_ie.js"></script><![endif]--><script>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</script><link rel="amphtml" href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/amp/"><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/timesdelphic.com\/#organization","url":"https:\/\/timesdelphic.com\/","name":"\"\"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/jegtheme\/","https:\/\/twitter.com\/jegtheme","#","#"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/timesdelphic.com\/#website","url":"https:\/\/timesdelphic.com\/","name":"\"\"","potentialAction":{"@type":"SearchAction","target":"https:\/\/timesdelphic.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="icon" href="https://timesdelphic.com/wp-content/uploads/2019/02/cropped-Screen-Shot-2019-02-28-at-3.49.29-PM-32x32.png" sizes="32x32" />
<link rel="icon" href="https://timesdelphic.com/wp-content/uploads/2019/02/cropped-Screen-Shot-2019-02-28-at-3.49.29-PM-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://timesdelphic.com/wp-content/uploads/2019/02/cropped-Screen-Shot-2019-02-28-at-3.49.29-PM-180x180.png" />
<meta name="msapplication-TileImage" content="https://timesdelphic.com/wp-content/uploads/2019/02/cropped-Screen-Shot-2019-02-28-at-3.49.29-PM-270x270.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">
					.no_thumbnail .jeg_thumb,
					.thumbnail-container.no_thumbnail {
					    display: none !important;
					}
					.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_pl_sm.no_thumbnail .jeg_postblock_content {
					    margin-left: 0;
					}
					.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content  {
					    margin-top: 0;
					}
					.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content {
					    position: relative;
					}
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
					    color: #212121 !important;
					} 
				</style></head>
<body class="post-template-default single single-post postid-34193 single-format-standard wp-embed-responsive browser-unknown aesop-core aesop-on-jnews jeg_toggle_dark jeg_single_tpl_2 jnews jsc_normal elementor-default elementor-kit-31451">


    
    
    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_topbar jeg_container dark">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left  jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
	<ul class="jeg_menu jeg_top_menu"><li id="menu-item-31538" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31538"><a href="https://timesdelphic.com/">Home</a></li>
<li id="menu-item-28501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28501"><a href="https://timesdelphic.com/about/staff/">Staff</a></li>
<li id="menu-item-28502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28502"><a href="https://timesdelphic.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-28506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28506"><a href="https://timesdelphic.com/about/news-tips/">News Tips/Press Releases</a></li>
<li id="menu-item-28505" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28505"><a href="https://timesdelphic.com/advertising/">Advertising</a></li>
</ul></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center  jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_top_date">
    Wednesday, April 13, 2022</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right  jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Search Form -->
<div class="jeg_nav_item jeg_nav_search">
	<div class="jeg_search_wrapper jeg_search_no_expand square">
	    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	    <form action="https://timesdelphic.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div>	</div>
</div>                    </div>
                </div>

                        </div>
    </div>
</div><!-- /.jeg_container --><div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="https://timesdelphic.com/" style="padding: 0 0 0 0;">
	    	    The Times-Delphic	    	</a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignright">
                                            </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper 1 jeg_navbar_boxed jeg_navbar_fitwidth jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animate"><li id="menu-item-31398" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-31398 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/news/">News</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="3" class="active"><a href="https://timesdelphic.com/category/news/">All</a></li>
                        <li data-cat-id="4521" class=""><a href="https://timesdelphic.com/category/news/administrative-news/">Administrative News</a></li><li data-cat-id="608" class=""><a href="https://timesdelphic.com/category/news/campus-events/">Campus Events</a></li><li data-cat-id="4539" class=""><a href="https://timesdelphic.com/category/news/campus-health/">Campus Health</a></li><li data-cat-id="3503" class=""><a href="https://timesdelphic.com/category/news/caucusroundup/">Caucus Roundup</a></li><li data-cat-id="2760" class=""><a href="https://timesdelphic.com/category/news/in-des-moines-news/">In Des Moines</a></li><li data-cat-id="4547" class=""><a href="https://timesdelphic.com/category/news/politics/">Politics</a></li><li data-cat-id="4546" class=""><a href="https://timesdelphic.com/category/news/student-politics/">Student Politics</a></li><li data-cat-id="399" class=""><a href="https://timesdelphic.com/category/news/student-senate/">Student Senate</a></li><li data-cat-id="5446" class=""><a href="https://timesdelphic.com/category/news/the-ones/">The Ones</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="3" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/breaking-provost-announces-action-plan-on-racist-incidents/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/Crawford1-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/breaking-provost-announces-action-plan-on-racist-incidents/">Breaking: Provost announces action plan on racist incidents</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/">Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/elementor-34182/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Man dies in shooting a few houses down from Greek Street" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/image_from_ios_720-2-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/elementor-34182/">Man dies in shooting a few houses down from Greek Street</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34166/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Holiday-inn-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34166/">Campus Suites at Dogtown to provide new housing opportunity for students</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34149/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Snookies-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34149/">Snookie&#8217;s Malt Shop Reopens</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li id="menu-item-31399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31399 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/administrative-news/">Administrative News</a></li>
	<li id="menu-item-33562" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33562 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/the-ones/">The Ones</a></li>
	<li id="menu-item-31400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31400 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/campus-events/">Campus Events</a></li>
	<li id="menu-item-31401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31401 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/campus-health/">Campus Health</a></li>
	<li id="menu-item-31402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31402 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/caucusroundup/">Caucus Roundup</a></li>
	<li id="menu-item-31403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31403 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/in-des-moines-news/">In Des Moines</a></li>
	<li id="menu-item-31404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31404 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/politics/">Politics</a></li>
	<li id="menu-item-31405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31405 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/student-politics/">Student Politics</a></li>
	<li id="menu-item-31406" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31406 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/student-senate/">Student Senate</a></li>
	<li id="menu-item-31407" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31407 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/student-senate/senate-elections/">Senate Elections</a></li>
</ul>
</li>
<li id="menu-item-31408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31408 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/sports/">Sports</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="5" class="active"><a href="https://timesdelphic.com/category/sports/">All</a></li>
                        <li data-cat-id="4580" class=""><a href="https://timesdelphic.com/category/sports/baseball/">Baseball</a></li><li data-cat-id="4523" class=""><a href="https://timesdelphic.com/category/sports/mens-basketball/">Basketball</a></li><li data-cat-id="719" class=""><a href="https://timesdelphic.com/category/sports/column/">Column</a></li><li data-cat-id="4524" class=""><a href="https://timesdelphic.com/category/sports/cross-country/">Cross-Country</a></li><li data-cat-id="4552" class=""><a href="https://timesdelphic.com/category/sports/e-sports/">E-Sports</a></li><li data-cat-id="4522" class=""><a href="https://timesdelphic.com/category/sports/football/">Football</a></li><li data-cat-id="4525" class=""><a href="https://timesdelphic.com/category/sports/golf/">Golf</a></li><li data-cat-id="4531" class=""><a href="https://timesdelphic.com/category/sports/rowing/">Rowing</a></li><li data-cat-id="4526" class=""><a href="https://timesdelphic.com/category/sports/mens-soccer/">Soccer</a></li><li data-cat-id="4533" class=""><a href="https://timesdelphic.com/category/sports/softball/">Softball</a></li><li data-cat-id="4527" class=""><a href="https://timesdelphic.com/category/sports/mens-tennis/">Tennis</a></li><li data-cat-id="4529" class=""><a href="https://timesdelphic.com/category/sports/track-and-field/">Track and Field</a></li><li data-cat-id="4534" class=""><a href="https://timesdelphic.com/category/sports/volleyball/">Volleyball</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="5" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34158/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/usmnt--360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34158/">USMNT drawn for 2022 Qatar World Cup</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34160/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Aliyah_Boston-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34160/">Women&#8217;s March Madness</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34156/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/GB-packers-sideline-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34156/">The Packers need to replace Davante Adams</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34147/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Drake Women&#8217;s Tennis gets new assistant coach" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/02/Tennis_Racket_and_Balls-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34147/">Men&#8217;s tennis earns Summit Player of the Week award</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34093/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34093/">Ranking &#038; Grading the Top Moves from NFL Free Agency</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li id="menu-item-31409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31409 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/mens-basketball/">Basketball</a></li>
	<li id="menu-item-31410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31410 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/column/">Column</a></li>
	<li id="menu-item-31411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31411 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/cross-country/">Cross-Country</a></li>
	<li id="menu-item-31412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31412 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/e-sports/">E-Sports</a></li>
	<li id="menu-item-31413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31413 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/football/">Football</a></li>
	<li id="menu-item-31414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31414 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/golf/">Golf</a></li>
	<li id="menu-item-31415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31415 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/rowing/">Rowing</a></li>
	<li id="menu-item-31416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31416 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/mens-soccer/">Soccer</a></li>
	<li id="menu-item-31417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31417 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/softball/">Softball</a></li>
</ul>
</li>
<li id="menu-item-31418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31418 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/">Commentary</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4873" class="active"><a href="https://timesdelphic.com/category/commentary/">All</a></li>
                        <li data-cat-id="4924" class=""><a href="https://timesdelphic.com/category/commentary/horoscope/">Horoscope</a></li><li data-cat-id="4963" class=""><a href="https://timesdelphic.com/category/commentary/letter-from-the-editor/">Letter from the Editor</a></li><li data-cat-id="5254" class=""><a href="https://timesdelphic.com/category/commentary/letter-to-the-editor-commentary/">Letter to the Editor</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="4873" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34153/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commentary: The fresh menace of the Oscars" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/404px-TechCrunch_Disrupt_2019_48834434641_cropped-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34153/">Commentary: The fresh menace of the Oscars</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34144/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commentary: Student Workers of the World, Unite!" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/pexels-ahsanjaya-8719576-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34144/">Commentary: Student Workers of the World, Unite!</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34099/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34099/">Best hammock spots in Des Moines</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34097/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34097/">A Deeper Look Into the Recent NFL Suspensions</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34101/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/movie-review-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34101/">&#8220;Jujutsu Kaisen 0&#8221; Movie Review</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li id="menu-item-31419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31419 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/horoscope/">Horoscope</a></li>
	<li id="menu-item-31420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31420 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/letter-from-the-editor/">Letter from the Editor</a></li>
</ul>
</li>
<li id="menu-item-31428" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31428 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/features/">Features</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4" class="active"><a href="https://timesdelphic.com/category/features/">All</a></li>
                        <li data-cat-id="193" class=""><a href="https://timesdelphic.com/category/features/greek-life/">Greek Life</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="4" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34151/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Working_from_home-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34151/">Drake Professor reveals research on remote work</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34142/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34142/">DSM Playhouse presents &#8216;Singing in the Rain&#8217;</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34162/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/waystowastetime-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34162/">Features: What&#8217;s your favorite way to waste time?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34164/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/thelegendsartexhibit-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34164/">Weeks Gallery Exhibition: Las Leyendas/Legends</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34091/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34091/">Professional Profiles: Paige Jansen</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li id="menu-item-31429" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31429 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/features/greek-life/">Greek Life</a></li>
</ul>
</li>
<li id="menu-item-28888" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28888 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/podcast-2/">Podcasts</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix">
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="117" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel no_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2018/12/drake-weekly-sports-podcast-december-3/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Drake Weekly Sports Podcast | December 3" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://timesdelphic.com/wp-content/uploads/2018/12/Drake-Sports-Recap.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2018/12/drake-weekly-sports-podcast-december-3/">Drake Weekly Sports Podcast | December 3</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2018/04/drake-public-safety-and-the-student-body/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Drake Public Safety and the student body" loading="lazy" sizes="(max-width: 270px) 100vw, 270px" data-src="https://timesdelphic.com/wp-content/uploads/2018/04/DrakePublicSafetyDept_YingChyiGooi.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2018/04/drake-public-safety-and-the-student-body/">Drake Public Safety and the student body</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2017/04/humans-of-drake-podcast/"><div class="thumbnail-container size-500 "><img width="360" height="171" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2014/11/20170415_Jim_Duncan_Invitational-Prac-for-Relays-2017_136-e1493069184157.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2017/04/humans-of-drake-podcast/">Humans of Drake Podcast</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2010/12/bulldog-blitz-1/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2010/12/bulldog-blitz-1/">Bulldog Blitz 1: December 7, 2010</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2010/11/the-sports-report-2010-7-11092010/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2010/11/the-sports-report-2010-7-11092010/">The Sports Report 2010 7: 11/09/2010</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div></li>
<li id="menu-item-28236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28236 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://timesdelphic.com/category/relays-edition/">Relays Edition</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix">
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="148" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel no_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/relays2022theme/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Student Activities Board announces 2022 Drake Relays theme" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/Screen-Shot-2022-03-24-at-10.03.42-PM-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/relays2022theme/">Student Activities Board announces 2022 Drake Relays theme</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/02/student-activities-board-predicts-return-of-relays-traditions/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The 101 on Relays 2021" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/relaysrgb-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/02/student-activities-board-predicts-return-of-relays-traditions/">Student Activities Board predicts return of Relays traditions</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/run-for-your-life/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Run for your Life" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/running-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/run-for-your-life/">Run for your Life</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/the-view-from-57000-feet/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fraternity friends, sorority sweethearts and Peggy&#8217;s pals" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/BILL-LOVE-240x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/the-view-from-57000-feet/">The view from 57,000 feet</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/fraternity-friends-sorority-sweethearts-and-peggys-pals/"><div class="thumbnail-container size-500 "><img width="356" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fraternity friends, sorority sweethearts and Peggy&#8217;s pals" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/BILL-JACKSON-356x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/fraternity-friends-sorority-sweethearts-and-peggys-pals/">Fraternity friends, sorority sweethearts and Peggy&#8217;s pals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/a-toast-to-tradition-reminiscing-on-past-relays/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="A toast to tradition: Reminiscing  on past Relays" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/Tug-GRRR-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/a-toast-to-tradition-reminiscing-on-past-relays/">A toast to tradition: Reminiscing  on past Relays</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/chariots-of-fire-2-drake-road-races/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Annual Drake Road Races return for Relays" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/road-races-page-22-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/chariots-of-fire-2-drake-road-races/">Chariots of Fire 2: Drake Road Races</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/hot-girl-summer-prep/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Hot Girl Summer prep" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/hot-girl-summer-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/hot-girl-summer-prep/">Hot Girl Summer prep</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/the-sports-spark-is-gone/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The sports spark is gone" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/baseball-field-1149153_1920-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/the-sports-spark-is-gone/">The sports spark is gone</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li id="menu-item-31430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31430 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/">Commentary</a></li>
	<li id="menu-item-31431" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31431 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/coronavirus/">Coronavirus</a></li>
	<li id="menu-item-31432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31432 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/elections/">Elections</a></li>
	<li id="menu-item-31433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31433 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/features/">Features</a></li>
	<li id="menu-item-31434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31434 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/in-des-moines/">In Des Moines</a></li>
	<li id="menu-item-31435" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31435 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/">News</a></li>
	<li id="menu-item-31436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31436 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/weekinphotos/">This week in photos</a></li>
	<li id="menu-item-31437" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31437 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/top-news/">Top News</a></li>
	<li id="menu-item-31438" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31438 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/top-stories/">Top Stories</a></li>
	<li id="menu-item-31439" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31439 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/uncategorized/">Uncategorized</a></li>
	<li id="menu-item-31440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31440 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/video/">Video</a></li>
	<li id="menu-item-31441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31441 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/">Sports</a></li>
	<li id="menu-item-31442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31442 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/securityreports/">Security Reports</a></li>
	<li id="menu-item-31443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31443 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/relays-edition/">Relays Edition</a></li>
	<li id="menu-item-31445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31445 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/poll/">Poll</a></li>
	<li id="menu-item-31444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31444 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/podcasts/">Podcasts</a></li>
	<li id="menu-item-31446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31446 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/online/">Online Exclusives</a></li>
	<li id="menu-item-31447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31447 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/opinion/">Opinion</a></li>
</ul>
</li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_dark_mode">
                    <label class="dark_mode_switch">
                        <input type="checkbox" class="jeg_dark_mode_toggle" >
                        <span class="slider round"></span>
                    </label>
                 </div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper  jeg_navbar_fitwidth jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignleft">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                <div class="item_wrap jeg_nav_aligncenter">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animate"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-31398 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/news/">News</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="3" class="active"><a href="https://timesdelphic.com/category/news/">All</a></li>
                        <li data-cat-id="4521" class=""><a href="https://timesdelphic.com/category/news/administrative-news/">Administrative News</a></li><li data-cat-id="608" class=""><a href="https://timesdelphic.com/category/news/campus-events/">Campus Events</a></li><li data-cat-id="4539" class=""><a href="https://timesdelphic.com/category/news/campus-health/">Campus Health</a></li><li data-cat-id="3503" class=""><a href="https://timesdelphic.com/category/news/caucusroundup/">Caucus Roundup</a></li><li data-cat-id="2760" class=""><a href="https://timesdelphic.com/category/news/in-des-moines-news/">In Des Moines</a></li><li data-cat-id="4547" class=""><a href="https://timesdelphic.com/category/news/politics/">Politics</a></li><li data-cat-id="4546" class=""><a href="https://timesdelphic.com/category/news/student-politics/">Student Politics</a></li><li data-cat-id="399" class=""><a href="https://timesdelphic.com/category/news/student-senate/">Student Senate</a></li><li data-cat-id="5446" class=""><a href="https://timesdelphic.com/category/news/the-ones/">The Ones</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="3" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/breaking-provost-announces-action-plan-on-racist-incidents/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/Crawford1-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/breaking-provost-announces-action-plan-on-racist-incidents/">Breaking: Provost announces action plan on racist incidents</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/">Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/elementor-34182/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Man dies in shooting a few houses down from Greek Street" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/image_from_ios_720-2-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/elementor-34182/">Man dies in shooting a few houses down from Greek Street</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34166/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Holiday-inn-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34166/">Campus Suites at Dogtown to provide new housing opportunity for students</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34149/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Snookies-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34149/">Snookie&#8217;s Malt Shop Reopens</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31399 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/administrative-news/">Administrative News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33562 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/the-ones/">The Ones</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31400 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/campus-events/">Campus Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31401 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/campus-health/">Campus Health</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31402 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/caucusroundup/">Caucus Roundup</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31403 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/in-des-moines-news/">In Des Moines</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31404 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/politics/">Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31405 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/student-politics/">Student Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31406 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/student-senate/">Student Senate</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31407 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/student-senate/senate-elections/">Senate Elections</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31408 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/sports/">Sports</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="5" class="active"><a href="https://timesdelphic.com/category/sports/">All</a></li>
                        <li data-cat-id="4580" class=""><a href="https://timesdelphic.com/category/sports/baseball/">Baseball</a></li><li data-cat-id="4523" class=""><a href="https://timesdelphic.com/category/sports/mens-basketball/">Basketball</a></li><li data-cat-id="719" class=""><a href="https://timesdelphic.com/category/sports/column/">Column</a></li><li data-cat-id="4524" class=""><a href="https://timesdelphic.com/category/sports/cross-country/">Cross-Country</a></li><li data-cat-id="4552" class=""><a href="https://timesdelphic.com/category/sports/e-sports/">E-Sports</a></li><li data-cat-id="4522" class=""><a href="https://timesdelphic.com/category/sports/football/">Football</a></li><li data-cat-id="4525" class=""><a href="https://timesdelphic.com/category/sports/golf/">Golf</a></li><li data-cat-id="4531" class=""><a href="https://timesdelphic.com/category/sports/rowing/">Rowing</a></li><li data-cat-id="4526" class=""><a href="https://timesdelphic.com/category/sports/mens-soccer/">Soccer</a></li><li data-cat-id="4533" class=""><a href="https://timesdelphic.com/category/sports/softball/">Softball</a></li><li data-cat-id="4527" class=""><a href="https://timesdelphic.com/category/sports/mens-tennis/">Tennis</a></li><li data-cat-id="4529" class=""><a href="https://timesdelphic.com/category/sports/track-and-field/">Track and Field</a></li><li data-cat-id="4534" class=""><a href="https://timesdelphic.com/category/sports/volleyball/">Volleyball</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="5" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34158/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/usmnt--360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34158/">USMNT drawn for 2022 Qatar World Cup</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34160/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Aliyah_Boston-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34160/">Women&#8217;s March Madness</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34156/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/GB-packers-sideline-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34156/">The Packers need to replace Davante Adams</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34147/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Drake Women&#8217;s Tennis gets new assistant coach" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/02/Tennis_Racket_and_Balls-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34147/">Men&#8217;s tennis earns Summit Player of the Week award</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34093/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34093/">Ranking &#038; Grading the Top Moves from NFL Free Agency</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31409 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/mens-basketball/">Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31410 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/column/">Column</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31411 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/cross-country/">Cross-Country</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31412 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/e-sports/">E-Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31413 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/football/">Football</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31414 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/golf/">Golf</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31415 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/rowing/">Rowing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31416 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/mens-soccer/">Soccer</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31417 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/softball/">Softball</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31418 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/">Commentary</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4873" class="active"><a href="https://timesdelphic.com/category/commentary/">All</a></li>
                        <li data-cat-id="4924" class=""><a href="https://timesdelphic.com/category/commentary/horoscope/">Horoscope</a></li><li data-cat-id="4963" class=""><a href="https://timesdelphic.com/category/commentary/letter-from-the-editor/">Letter from the Editor</a></li><li data-cat-id="5254" class=""><a href="https://timesdelphic.com/category/commentary/letter-to-the-editor-commentary/">Letter to the Editor</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="4873" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34153/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commentary: The fresh menace of the Oscars" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/404px-TechCrunch_Disrupt_2019_48834434641_cropped-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34153/">Commentary: The fresh menace of the Oscars</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34144/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commentary: Student Workers of the World, Unite!" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/pexels-ahsanjaya-8719576-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34144/">Commentary: Student Workers of the World, Unite!</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34099/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34099/">Best hammock spots in Des Moines</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34097/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34097/">A Deeper Look Into the Recent NFL Suspensions</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34101/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/movie-review-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34101/">&#8220;Jujutsu Kaisen 0&#8221; Movie Review</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31419 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/horoscope/">Horoscope</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31420 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/letter-from-the-editor/">Letter from the Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31428 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/category/features/">Features</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix"><div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4" class="active"><a href="https://timesdelphic.com/category/features/">All</a></li>
                        <li data-cat-id="193" class=""><a href="https://timesdelphic.com/category/features/greek-life/">Greek Life</a></li>
                    </ul>
                </div>
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="4" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel with_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34151/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/Working_from_home-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34151/">Drake Professor reveals research on remote work</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34142/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34142/">DSM Playhouse presents &#8216;Singing in the Rain&#8217;</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34162/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/waystowastetime-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34162/">Features: What&#8217;s your favorite way to waste time?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/04/34164/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/04/thelegendsartexhibit-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/04/34164/">Weeks Gallery Exhibition: Las Leyendas/Legends</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/34091/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/34091/">Professional Profiles: Paige Jansen</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31429 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/features/greek-life/">Greek Life</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28888 bgnav jeg_megamenu category_1" data-number="5"  data-item-row="default" ><a href="https://timesdelphic.com/podcast-2/">Podcasts</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix">
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="117" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel no_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2018/12/drake-weekly-sports-podcast-december-3/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Drake Weekly Sports Podcast | December 3" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://timesdelphic.com/wp-content/uploads/2018/12/Drake-Sports-Recap.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2018/12/drake-weekly-sports-podcast-december-3/">Drake Weekly Sports Podcast | December 3</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2018/04/drake-public-safety-and-the-student-body/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Drake Public Safety and the student body" loading="lazy" sizes="(max-width: 270px) 100vw, 270px" data-src="https://timesdelphic.com/wp-content/uploads/2018/04/DrakePublicSafetyDept_YingChyiGooi.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2018/04/drake-public-safety-and-the-student-body/">Drake Public Safety and the student body</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2017/04/humans-of-drake-podcast/"><div class="thumbnail-container size-500 "><img width="360" height="171" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2014/11/20170415_Jim_Duncan_Invitational-Prac-for-Relays-2017_136-e1493069184157.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2017/04/humans-of-drake-podcast/">Humans of Drake Podcast</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2010/12/bulldog-blitz-1/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2010/12/bulldog-blitz-1/">Bulldog Blitz 1: December 7, 2010</a></h3>
                </div><div class="jeg_newsfeed_item no_thumbnail">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2010/11/the-sports-report-2010-7-11092010/"><div class="thumbnail-container size-500 "></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2010/11/the-sports-report-2010-7-11092010/">The Sports Report 2010 7: 11/09/2010</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28236 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://timesdelphic.com/category/relays-edition/">Relays Edition</a><div class="sub-menu">
                    <div class="jeg_newsfeed clearfix">
                <div class="jeg_newsfeed_list">
                    <div data-cat-id="148" data-load-status="loaded" class="jeg_newsfeed_container">
                        <div class="newsfeed_carousel owl-carousel no_subcat">
                            <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/03/relays2022theme/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Student Activities Board announces 2022 Drake Relays theme" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/Screen-Shot-2022-03-24-at-10.03.42-PM-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/03/relays2022theme/">Student Activities Board announces 2022 Drake Relays theme</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2022/02/student-activities-board-predicts-return-of-relays-traditions/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The 101 on Relays 2021" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/relaysrgb-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2022/02/student-activities-board-predicts-return-of-relays-traditions/">Student Activities Board predicts return of Relays traditions</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/run-for-your-life/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Run for your Life" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/running-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/run-for-your-life/">Run for your Life</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/the-view-from-57000-feet/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fraternity friends, sorority sweethearts and Peggy&#8217;s pals" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/BILL-LOVE-240x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/the-view-from-57000-feet/">The view from 57,000 feet</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/fraternity-friends-sorority-sweethearts-and-peggys-pals/"><div class="thumbnail-container size-500 "><img width="356" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fraternity friends, sorority sweethearts and Peggy&#8217;s pals" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/BILL-JACKSON-356x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/fraternity-friends-sorority-sweethearts-and-peggys-pals/">Fraternity friends, sorority sweethearts and Peggy&#8217;s pals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/a-toast-to-tradition-reminiscing-on-past-relays/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="A toast to tradition: Reminiscing  on past Relays" loading="lazy" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/Tug-GRRR-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/a-toast-to-tradition-reminiscing-on-past-relays/">A toast to tradition: Reminiscing  on past Relays</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/chariots-of-fire-2-drake-road-races/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Annual Drake Road Races return for Relays" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/road-races-page-22-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/chariots-of-fire-2-drake-road-races/">Chariots of Fire 2: Drake Road Races</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/hot-girl-summer-prep/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Hot Girl Summer prep" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/hot-girl-summer-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/hot-girl-summer-prep/">Hot Girl Summer prep</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://timesdelphic.com/2021/04/the-sports-spark-is-gone/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The sports spark is gone" loading="lazy" sizes="(max-width: 360px) 100vw, 360px" data-src="https://timesdelphic.com/wp-content/uploads/2021/04/baseball-field-1149153_1920-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://timesdelphic.com/2021/04/the-sports-spark-is-gone/">The sports spark is gone</a></h3>
                </div>
                        </div>
                    </div>
                    <div class="newsfeed_overlay">
                    <div class="preloader_type preloader_circle">
                        <div class="newsfeed_preloader jeg_preloader dot">
                            <span></span><span></span><span></span>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader circle">
                            <div class="jnews_preloader_circle_outer">
                                <div class="jnews_preloader_circle_inner"></div>
                            </div>
                        </div>
                        <div class="newsfeed_preloader jeg_preloader square">
                            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                        </div>
                    </div>
                </div>
                </div></div>
                </div>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31430 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/commentary/">Commentary</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31431 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/coronavirus/">Coronavirus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31432 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/elections/">Elections</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31433 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/features/">Features</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31434 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/in-des-moines/">In Des Moines</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31435 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/news/">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31436 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/weekinphotos/">This week in photos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31437 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/top-news/">Top News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31438 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/top-stories/">Top Stories</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31439 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/uncategorized/">Uncategorized</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31440 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/video/">Video</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31441 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/sports/">Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31442 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/securityreports/">Security Reports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31443 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/relays-edition/">Relays Edition</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31445 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/poll/">Poll</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31444 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/podcasts/">Podcasts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31446 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/online/">Online Exclusives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31447 bgnav" data-item-row="default" ><a href="https://timesdelphic.com/category/opinion/">Opinion</a></li>
</ul>
</li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://timesdelphic.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://timesdelphic.com/">
		        The Times-Delphic		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://timesdelphic.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
    <div class="container">

        <div class="jeg_ad jeg_article_top jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>

        
                        <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                <div id="breadcrumbs"><span class="">
                <a href="https://timesdelphic.com">Home</a>
            </span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
                <a href="https://timesdelphic.com/category/top-news/">Top News</a>
            </span></div>            </div>
            
            <div class="entry-header">
	            
                <h1 class="jeg_post_title">Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators</h1>

                
                <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_2">

						<div class="jeg_meta_author coauthor">
				<span class="meta_text ">by</span><a href="https://timesdelphic.com/author/andrew-kennard/">Andrew Kennard</a>			</div>
			
			<div class="jeg_meta_date">
			<a href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/">April 13, 2022</a>
		</div>
	
			<div class="jeg_meta_category">
			<span><span class="meta_text">in</span>
				<a href="https://timesdelphic.com/category/news/" rel="category tag">News</a>, <a href="https://timesdelphic.com/category/news/student-senate/senate-elections/" rel="category tag">Senate Elections</a>, <a href="https://timesdelphic.com/category/news/student-senate/" rel="category tag">Student Senate</a>			</span>
		</div>
	
	
	<div class="meta_right">
		<div class='jeg_meta_like_container jeg_meta_like'>
                <a class='like' href='#' data-id='34193' data-type='like' data-message=''>
                        <i class='fa fa-thumbs-o-up'></i> <span>0</span>
                    </a><a class='dislike' href='#' data-id='34193' data-type='dislike' data-message=''>
                        <i class='fa fa-thumbs-o-down fa-flip-horizontal'></i> <span>0</span>
                    </a>
            </div>					<div class="jeg_meta_comment"><a href="https://timesdelphic.com/2022/04/2022-student-senate-candidates/#comments"><i
						class="fa fa-comment-o"></i> 0</a></div>
			</div>
</div>
</div>
            </div>

            <div class="row">
                <div class="jeg_main_content col-md-8">

                    <div class="jeg_inner_content">
                        <div class="jeg_featured featured_image"></div>
                        
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
                        <div class="entry-content no-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
                                                            </div>

                            <div class="content-inner ">
                                <p><em>Update: Graciela Breton-Solano says she has won the Equity and Inclusion senator position through UNITY, Areli Herrera has decided to withdraw from the race for Equity and Inclusion Senator and Michael Mitchell has emailed the election commission to withdraw from the SJMC Senator race.</em></p>
<p><span style="font-weight: 400;">Campaigning has begun for the general election for the 2022-2023 Drake University Student Senate. Voting will begin at 8 a.m. on Thursday, April 14 on </span><a href="https://webapps.drake.edu/onlineballoting/"><span style="font-weight: 400;">MyDrake</span></a><span style="font-weight: 400;"> and close at 8 p.m. on April 15. The Times-Delphic will moderate a candidate forum on Wednesday at 7 p.m.</span></p>
<p><i><span style="font-weight: 400;">This is a developing story. The Times-Delphic has sent questions to candidates and expects to publish their responses by Wednesday morning. </span></i></p>
<p><b>Senator-at-Large (6 positions available)</b></p>
<p><span style="font-weight: 400;">After the election, Senators-at-Large will each take up one of the following senate positions: Academic Affairs, Civic Engagement, Community Outreach, Facilities and Technology, Health and Safety or University Services. Each senator chairs a corresponding committee and has distinct responsibilities related to the above aspects of Drake. Each Senator-at-Large holds at least one office hour each week.</span></p>
<ol>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Daja Lucas</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Alisha Lonon</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Alex Frank</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Grant Morgan</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Breckyn Lyons</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Andrew Klinke </span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Aaron Khan-Gumm</span></li>
</ol>
<p><b>Equity and Inclusion Senator</b></p>
<p><span style="font-weight: 400;">Equity and Inclusion Senators serve as the co-chairs of UNITY Roundtable. UNITY carries out the election of one of these senators, while the student body elects the other. </span></p>
<p><span style="font-weight: 400;">The Equity and Inclusion Senator is responsible for “[seeking] to maintain a voice and vote of diversity on the floor of the Student Senate” and advocating for “awareness and education” of equity and inclusion issues, according to senate bylaws. They also “[act] as a liaison” between the President’s Panel and UNITY Roundtable and hold a minimum of one office hour each week.</span></p>
<ol>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Mylo Bissell</span></li>
</ol>
<p><b>Academic Senators</b></p>
<p><span style="font-weight: 400;">An Academic Senator meets with the dean, assistant or associate dean, or director of the college they represent at least once a month, according to senate bylaws. They must have declared a major in the college they represent. Academic Senators are called to “serve to further the needs and interests” of the students of their respective colleges and are required to hold at least one office hour each week. </span></p>
<p><i><span style="font-weight: 400;">School of Journalism and Mass Communication Senator</span></i></p>
<ol>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Gannon Henry</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Julia Cash</span></li>
</ol>
<p><i><span style="font-weight: 400;">College of Business and Public Administration Senator</span></i></p>
<ol>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Melissa Moxon</span></li>
</ol>
<p><i><span style="font-weight: 400;">College of Pharmacy and Health Sciences Senator</span></i></p>
<ol>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Kitri Reimer</span></li>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Stacia Humphrey</span></li>
</ol>
<p><i><span style="font-weight: 400;">College of Arts and Sciences Senator</span></i></p>
<ol>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Tiffany Lopez</span></li>
</ol>
<p><i><span style="font-weight: 400;">School of Education Senator</span></i></p>
<ol>
<li style="font-weight: 400;" aria-level="1"><span style="font-weight: 400;">Ben Connolly </span></li>
</ol>
                                
	                            
                                                            </div>

                            
                                                    </div>

                        <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container ">
	<div class="jeg_authorbox">
		<div class="jeg_author_image">
					</div>
		<div class="jeg_author_content">
			<h3 class="jeg_author_name">
				<a href="https://timesdelphic.com/author/andrew-kennard/">
					Andrew Kennard				</a>
			</h3>
			<p class="jeg_author_desc">
							</p>

							<div class="jeg_author_socials">
									</div>
			
		</div>
	</div>
</div><div class="jnews_related_post_container"></div><div class="jnews_popup_post_container">    <section class="jeg_popup_post">
        <span class="caption">Next Post</span>

                    <div class="jeg_popup_content">
                <div class="jeg_thumb">
                                        <a href="https://timesdelphic.com/2022/04/breaking-provost-announces-action-plan-on-racist-incidents/">
                        <div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="" loading="lazy" sizes="(max-width: 75px) 100vw, 75px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/Crawford1-1-75x75.jpg" data-srcset="https://timesdelphic.com/wp-content/uploads/2022/03/Crawford1-1-75x75.jpg 75w, https://timesdelphic.com/wp-content/uploads/2022/03/Crawford1-1-300x300.jpg 300w, https://timesdelphic.com/wp-content/uploads/2022/03/Crawford1-1-150x150.jpg 150w, https://timesdelphic.com/wp-content/uploads/2022/03/Crawford1-1-200x200.jpg 200w" data-sizes="auto" data-expand="700" /><div class="ccfic"></div></div>                    </a>
                </div>
                <h3 class="post-title">
                    <a href="https://timesdelphic.com/2022/04/breaking-provost-announces-action-plan-on-racist-incidents/">
                        Breaking: Provost announces action plan on racist incidents                    </a>
                </h3>
            </div>
                
        <a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
    </section>
</div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/04/2022-student-senate-candidates/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://timesdelphic.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='34193' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9057ef540a" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="29"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	</div>                    </div>

                </div>
                
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
    <div class="widget_text widget  jeg_pb_boxed widget_custom_html" id="custom_html-5"><div class="jeg_block_heading jeg_block_heading_6 jnews_62571641d01ab"><h3 class="jeg_block_title"><span>Twitter Feeds</span></h3></div><div class="textwidget custom-html-widget">	<div id="twitter-feed-timesdelphic" class="feed_dynamic_classvechwwghpc_twitter fts-twitter-div 
									 "
							>
			
						
			<div class="fts-tweeter-wrap "
									>
				<div class="tweeter-info">

												<div class="fts-twitter-image">
															<a href="https://twitter.com/timesdelphic" target="_blank" class="fts-twitter-username" rel="noopener"><img class="twitter-image" src="https://pbs.twimg.com/profile_images/1377834509362733058/2M7UtH7D_normal.jpg" alt="The Times-Delphic"/></a>
													</div>
					
					<div class="
																		fts-right">
						<div class="fts-uppercase fts-bold">

																	<a href="https://twitter.com/timesdelphic" target="_blank" class="fts-twitter-full-name" rel="noopener">The Times-Delphic</a>
								<a href="https://twitter.com/timesdelphic" target="_blank" class="fts-twitter-at-name" rel="noopener">@timesdelphic</a>
										
						</div>

						<span class="time"><a href="https://twitter.com/timesdelphic/status/1514021596268220421" target="_blank" title=" " rel="noopener"> </a></span><br/>
						<span class="fts-twitter-text">
						BREAKING: Michael Mitchell said in a direct message that he has emailed the Election Commission to withdraw from the race for SJMC Senator. This leaves Julia Cash and Gannon Henry in the race.							<div class="fts-twitter-caption">
												<a href="https://twitter.com/timesdelphic" class="fts-view-on-twitter-link" target="_blank" rel="noopener">View on Twitter</a>
											</div>
										</span>

											</div>
					<div class="fts-twitter-reply-wrap
																		fts-twitter-no-margin-left">
									<div class="fts-share-wrap"><a href="javascript:;" class="ft-gallery-link-popup" title="Social Share Options"></a><div class="ft-gallery-share-wrap"><a href="https://www.facebook.com/sharer/sharer.php?u=https://twitter.com/timesdelphic/status/1514021596268220421" target="_blank" rel="noreferrer noopener" class="ft-galleryfacebook-icon" title="Share this post on Facebook"><i class="fa fa-facebook-square"></i></a><a href="https://twitter.com/intent/tweet?text=https://twitter.com/timesdelphic/status/1514021596268220421+BREAKING: Michael Mitchell said in a direct message that he has emailed the Election Commission to withdraw from the race for SJMC Senator. This leaves Julia Cash and Gannon Henry in the race." target="_blank" rel="noreferrer noopener" class="ft-gallerytwitter-icon" title="Share this post on Twitter"><i class="fa fa-twitter"></i></a><a href="https://plus.google.com/share?url=https://twitter.com/timesdelphic/status/1514021596268220421" target="_blank" rel="noreferrer noopener" class="ft-gallerygoogle-icon" title="Share this post on Google"><i class="fa fa-google-plus"></i></a><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://twitter.com/timesdelphic/status/1514021596268220421" target="_blank" rel="noreferrer noopener" class="ft-gallerylinkedin-icon" title="Share this post on Linkedin"><i class="fa fa-linkedin"></i></a><a href="mailto:?subject=Shared Link&amp;body=https://twitter.com/timesdelphic/status/1514021596268220421 - BREAKING: Michael Mitchell said in a direct message that he has emailed the Election Commission to withdraw from the race for SJMC Senator. This leaves Julia Cash and Gannon Henry in the race." target="_blank" rel="noreferrer noopener" class="ft-galleryemail-icon" title="Share this post in your email"><i class="fa fa-envelope"></i></a></div></div>					</div>
					<div class="fts-twitter-reply-wrap-left">
									<div class="fts-tweet-reply-left"><a href="https://twitter.com/timesdelphic/status/1514021596268220421" target="_blank" title="Reply" aria-label="Reply" rel="noopener"><div class="fts-twitter-reply"></div></a></div>						<div class="fts-tweet-others-right"><a href="https://twitter.com/intent/retweet?tweet_id=1514021596268220421&amp;related=timesdelphic" target="_blank" class="fts-twitter-retweet-wrap" title="Retweet" aria-label="Retweet" rel="noopener"><div class="fts-twitter-retweet">0</div></a><a href="https://twitter.com/intent/like?tweet_id=1514021596268220421&amp;related=timesdelphic" target="_blank" class="fts-twitter-favorites-wrap" title="Favorite" aria-label="Favorite" rel="noopener"><div class="fts-twitter-favorites">1</div></a></div>
					</div>
					<div class="fts-clear"></div>
				</div>			</div>
						
			<div class="fts-tweeter-wrap "
									>
				<div class="tweeter-info">

												<div class="fts-twitter-image">
															<a href="https://twitter.com/timesdelphic" target="_blank" class="fts-twitter-username" rel="noopener"><img class="twitter-image" src="https://pbs.twimg.com/profile_images/1377834509362733058/2M7UtH7D_normal.jpg" alt="The Times-Delphic"/></a>
													</div>
					
					<div class="
																		fts-right">
						<div class="fts-uppercase fts-bold">

																	<a href="https://twitter.com/timesdelphic" target="_blank" class="fts-twitter-full-name" rel="noopener">The Times-Delphic</a>
								<a href="https://twitter.com/timesdelphic" target="_blank" class="fts-twitter-at-name" rel="noopener">@timesdelphic</a>
										
						</div>

						<span class="time"><a href="https://twitter.com/timesdelphic/status/1514020857953370117" target="_blank" title=" " rel="noopener"> </a></span><br/>
						<span class="fts-twitter-text">
						BREAKING: Graciela Breton-Solano said in an email that she has won the position of Equity and Inclusion Senator through UNITY Roundtable. Areli Herrera said in an email that she is no longer pursuing the other E&amp;I Senator position, leaving Mylo Bissell to run unopposed.							<div class="fts-twitter-caption">
												<a href="https://twitter.com/timesdelphic" class="fts-view-on-twitter-link" target="_blank" rel="noopener">View on Twitter</a>
											</div>
										</span>

											</div>
					<div class="fts-twitter-reply-wrap
																		fts-twitter-no-margin-left">
									<div class="fts-share-wrap"><a href="javascript:;" class="ft-gallery-link-popup" title="Social Share Options"></a><div class="ft-gallery-share-wrap"><a href="https://www.facebook.com/sharer/sharer.php?u=https://twitter.com/timesdelphic/status/1514020857953370117" target="_blank" rel="noreferrer noopener" class="ft-galleryfacebook-icon" title="Share this post on Facebook"><i class="fa fa-facebook-square"></i></a><a href="https://twitter.com/intent/tweet?text=https://twitter.com/timesdelphic/status/1514020857953370117+BREAKING: Graciela Breton-Solano said in an email that she has won the position of Equity and Inclusion Senator through UNITY Roundtable. Areli Herrera said in an email that she is no longer pursuing the other E&amp;I Senator position, leaving Mylo Bissell to run unopposed." target="_blank" rel="noreferrer noopener" class="ft-gallerytwitter-icon" title="Share this post on Twitter"><i class="fa fa-twitter"></i></a><a href="https://plus.google.com/share?url=https://twitter.com/timesdelphic/status/1514020857953370117" target="_blank" rel="noreferrer noopener" class="ft-gallerygoogle-icon" title="Share this post on Google"><i class="fa fa-google-plus"></i></a><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://twitter.com/timesdelphic/status/1514020857953370117" target="_blank" rel="noreferrer noopener" class="ft-gallerylinkedin-icon" title="Share this post on Linkedin"><i class="fa fa-linkedin"></i></a><a href="mailto:?subject=Shared Link&amp;body=https://twitter.com/timesdelphic/status/1514020857953370117 - BREAKING: Graciela Breton-Solano said in an email that she has won the position of Equity and Inclusion Senator through UNITY Roundtable. Areli Herrera said in an email that she is no longer pursuing the other E&amp;I Senator position, leaving Mylo Bissell to run unopposed." target="_blank" rel="noreferrer noopener" class="ft-galleryemail-icon" title="Share this post in your email"><i class="fa fa-envelope"></i></a></div></div>					</div>
					<div class="fts-twitter-reply-wrap-left">
									<div class="fts-tweet-reply-left"><a href="https://twitter.com/timesdelphic/status/1514020857953370117" target="_blank" title="Reply" aria-label="Reply" rel="noopener"><div class="fts-twitter-reply"></div></a></div>						<div class="fts-tweet-others-right"><a href="https://twitter.com/intent/retweet?tweet_id=1514020857953370117&amp;related=timesdelphic" target="_blank" class="fts-twitter-retweet-wrap" title="Retweet" aria-label="Retweet" rel="noopener"><div class="fts-twitter-retweet">0</div></a><a href="https://twitter.com/intent/like?tweet_id=1514020857953370117&amp;related=timesdelphic" target="_blank" class="fts-twitter-favorites-wrap" title="Favorite" aria-label="Favorite" rel="noopener"><div class="fts-twitter-favorites">2</div></a></div>
					</div>
					<div class="fts-clear"></div>
				</div>			</div>
							</div>
					</div></div><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-1"><div  class='jeg_ad jeg_ad_module jnews_module_34193_0_62571641d203b   '><div class='ads-wrapper'><a href='http://bit.ly/jnewsio' target='_blank' class='adlink ads_image '>
								<img src='https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png' class='lazyload' data-src='https://timesdelphic.com/wp-content/uploads/2020/07/ad_300x600.jpg' alt='' data-pin-no-hover="true">
							</a></div></div></div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-1"><div  class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_34193_1_62571641d270c  normal " data-unique="jnews_module_34193_1_62571641d270c">
                <div class="jeg_block_heading jeg_block_heading_8 jeg_subcat_right">
                    <h3 class="jeg_block_title"><span>Recommended</span></h3>
                    
                </div>
                <div class="jeg_block_container">
                
                <div class="jeg_posts jeg_load_more_flag">
                <article class="jeg_post jeg_pl_sm format-standard">
                <div class="jeg_thumb">
                    
                    <a href="https://timesdelphic.com/2022/03/33973/"><div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Status of nonbinary sorority members" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-src="https://timesdelphic.com/wp-content/uploads/2022/03/panhel-rule-120x86.jpg" data-srcset="https://timesdelphic.com/wp-content/uploads/2022/03/panhel-rule-120x86.jpg 120w, https://timesdelphic.com/wp-content/uploads/2022/03/panhel-rule-350x250.jpg 350w, https://timesdelphic.com/wp-content/uploads/2022/03/panhel-rule-750x536.jpg 750w, https://timesdelphic.com/wp-content/uploads/2022/03/panhel-rule-1140x815.jpg 1140w" data-sizes="auto" data-expand="700" /><div class="ccfic"></div></div></a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://timesdelphic.com/2022/03/33973/">Status of nonbinary sorority members</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://timesdelphic.com/2022/03/33973/" ><i class="fa fa-clock-o"></i> 1 month ago</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_sm no_thumbnail format-standard">
                <div class="jeg_thumb">
                    
                    <a href="https://timesdelphic.com/2011/04/8035-lineup-announced-today/"><div class="thumbnail-container animate-lazy no_thumbnail size-715 "><div class="ccfic"></div></div></a>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://timesdelphic.com/2011/04/8035-lineup-announced-today/">80/35 Lineup Announced Today</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://timesdelphic.com/2011/04/8035-lineup-announced-today/" ><i class="fa fa-clock-o"></i> 11 years ago</a></div></div>
                </div>
            </article>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="jnews_preloader_circle_outer">
                            <div class="jnews_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                
                
            </div>
                
                <script>var jnews_module_34193_1_62571641d270c = {"header_icon":"","first_title":"Recommended","second_title":"","url":"","header_type":"heading_8","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"","post_type":"post","content_type":"all","number_post":"2","post_offset":"","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"random","date_format":"ago","date_format_custom":"","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"1","pagination_scroll_limit":"","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"};</script>
            </div></div><div class="widget  jeg_pb_boxed jeg_pb_boxed_shadow widget_jnews_popular" id="jnews_popular-1"><div class="jeg_block_heading jeg_block_heading_8 jnews_62571641d6768"><h3 class="jeg_block_title"><span>Popular News</span></h3></div><ul class="popularpost_list"><li class="popularpost_item format-standard">
                <div class="jeg_thumb">
                    
                    <a href="https://timesdelphic.com/2021/03/twitch-streamer-raises-money-for-lgbt-community/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://timesdelphic.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Twitch Streamer Raises Money for LGBT Community" loading="lazy" sizes="(max-width: 350px) 100vw, 350px" data-src="https://timesdelphic.com/wp-content/uploads/2021/03/twitch-350x250.jpg" data-srcset="https://timesdelphic.com/wp-content/uploads/2021/03/twitch-350x250.jpg 350w, https://timesdelphic.com/wp-content/uploads/2021/03/twitch-120x86.jpg 120w, https://timesdelphic.com/wp-content/uploads/2021/03/twitch-750x536.jpg 750w, https://timesdelphic.com/wp-content/uploads/2021/03/twitch-1140x815.jpg 1140w" data-sizes="auto" data-expand="700" /><div class="ccfic"></div></div></a>
                </div>
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2021/03/twitch-streamer-raises-money-for-lgbt-community/" data-num="01">Twitch Streamer Raises Money for LGBT Community</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2017/10/gladwells-outliers-shows-the-many-factors-of-success/" data-num="02">Gladwell&#8217;s &#8220;Outliers&#8221; reveals the many factors of success</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2015/11/drake-ranks-among-ivy-leagues-on-economist-list/" data-num="03">Drake ranks among Ivy Leagues on Economist list</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2021/10/the-history-of-indian-boarding-schools-in-iowa/" data-num="04">The history of Indian boarding schools in Iowa</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2018/12/drake-weekly-sports-podcast-december-3/" data-num="05">Drake Weekly Sports Podcast | December 3</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2011/02/music-as-a-political-platform/" data-num="06">Music as a political platform</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2017/04/humans-of-drake-podcast/" data-num="07">Humans of Drake Podcast</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2010/11/the-sports-report-2010-7-11092010/" data-num="08">The Sports Report 2010 7: 11/09/2010</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2019/02/familiar-face-helps-bring-massive-skatepark-to-des-moines/" data-num="09">Familiar face helps bring massive skatepark to Des Moines</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li><li class="popularpost_item format-standard">
                <h3 class="jeg_post_title">
                    <a href="https://timesdelphic.com/2010/11/the-rise-and-fall-of-motown-records/" data-num="10">The rise and fall of Motown Records</a>
                </h3>
                <div class="popularpost_meta">
                    <div class="jeg_socialshare">
                        <span class="share_count"><i class="fa fa-share-alt"></i> 0 shares</span>
                        <div class="socialshare_list">
                            <a href="" class="jeg_share_fb"><span class="share-text">Share</span> <span class="share-count">0</span></a>
                            <a href="" class="jeg_share_tw"><span class="share-text">Tweet</span> <span class="share-count">0</span></a>
                        </div>
                    </div>
                </div>
            </li></ul></div><div class="widget widget_jnews_social" id="jnews_social-2"><div class="jeg_block_heading jeg_block_heading_6 jnews_62571641df37f"><h3 class="jeg_block_title"><span>Connect with us</span></h3></div>
        <div class="jeg_social_wrap ">
			
            <div class="socials_widget   rounded">
				<a href="http://www.facebook.com/timesdelphic" target="_blank" class="jeg_facebook">
                                            <i class="fa fa-facebook"></i>
                                            
                                        </a><a href="http://www.twitter.com/timesdelphic" target="_blank" class="jeg_twitter">
                                            <i class="fa fa-twitter"></i>
                                            
                                        </a><a href="https://www.instagram.com/draketimesdelphic/" target="_blank" class="jeg_instagram">
                                            <i class="fa fa-instagram"></i>
                                            
                                        </a>            </div>

						<style scoped></style>        </div>

		</div></div>            </div>

        
        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '></div>        </div>

    </div>

</div>
                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-34193 single-format-standard wp-embed-responsive browser-unknown aesop-core aesop-on-jnews jeg_toggle_dark jeg_single_tpl_2 jnews jsc_normal elementor-default elementor-kit-31451"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_6 dark">
    <div class="jeg_footer_container jeg_container">

        <div class="jeg_footer_content">
            <div class="container">
                <div class="jeg_footer_primary clearfix">
                                    </div>
            </div>
        </div>

        <div class="jeg_footer_instagram_wrapper">
                    </div>

        
        <div class="jeg_footer_bottom">
            <div class="container">

                <!-- secondary footer right -->
                <div class="footer_right">

                    
                    
                    
                </div>

                <!-- secondary footer left -->
                
                <ul class="jeg_menu_footer"><li id="menu-item-31487" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31487"><a href="https://timesdelphic.com/about/">About</a></li>
<li id="menu-item-31547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-31547"><a href="https://timesdelphic.com/">Home</a></li>
<li id="menu-item-31492" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31492"><a href="https://timesdelphic.com/podcast-2/">Podcasts</a></li>
<li id="menu-item-31493" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31493"><a href="https://timesdelphic.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-31494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31494"><a href="https://timesdelphic.com/virtual/">Virtual Edition</a></li>
<li id="menu-item-31495" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31495"><a href="https://timesdelphic.com/advertising/">Advertising</a></li>
</ul>
                                    <p class="copyright"> Copyright 2015 Fuel Themes. All RIGHTS RESERVED. </p>
                
            </div>
        </div>

        
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand square">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://timesdelphic.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-31398"><a href="https://timesdelphic.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31399"><a href="https://timesdelphic.com/category/news/administrative-news/">Administrative News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33562"><a href="https://timesdelphic.com/category/news/the-ones/">The Ones</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31400"><a href="https://timesdelphic.com/category/news/campus-events/">Campus Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31401"><a href="https://timesdelphic.com/category/news/campus-health/">Campus Health</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31402"><a href="https://timesdelphic.com/category/news/caucusroundup/">Caucus Roundup</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31403"><a href="https://timesdelphic.com/category/news/in-des-moines-news/">In Des Moines</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31404"><a href="https://timesdelphic.com/category/news/politics/">Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31405"><a href="https://timesdelphic.com/category/news/student-politics/">Student Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31406"><a href="https://timesdelphic.com/category/news/student-senate/">Student Senate</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31407"><a href="https://timesdelphic.com/category/news/student-senate/senate-elections/">Senate Elections</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31408"><a href="https://timesdelphic.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31409"><a href="https://timesdelphic.com/category/sports/mens-basketball/">Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31410"><a href="https://timesdelphic.com/category/sports/column/">Column</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31411"><a href="https://timesdelphic.com/category/sports/cross-country/">Cross-Country</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31412"><a href="https://timesdelphic.com/category/sports/e-sports/">E-Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31413"><a href="https://timesdelphic.com/category/sports/football/">Football</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31414"><a href="https://timesdelphic.com/category/sports/golf/">Golf</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31415"><a href="https://timesdelphic.com/category/sports/rowing/">Rowing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31416"><a href="https://timesdelphic.com/category/sports/mens-soccer/">Soccer</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31417"><a href="https://timesdelphic.com/category/sports/softball/">Softball</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31418"><a href="https://timesdelphic.com/category/commentary/">Commentary</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31419"><a href="https://timesdelphic.com/category/commentary/horoscope/">Horoscope</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31420"><a href="https://timesdelphic.com/category/commentary/letter-from-the-editor/">Letter from the Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-31428"><a href="https://timesdelphic.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31429"><a href="https://timesdelphic.com/category/features/greek-life/">Greek Life</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28888"><a href="https://timesdelphic.com/podcast-2/">Podcasts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28236"><a href="https://timesdelphic.com/category/relays-edition/">Relays Edition</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31430"><a href="https://timesdelphic.com/category/commentary/">Commentary</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31431"><a href="https://timesdelphic.com/category/coronavirus/">Coronavirus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31432"><a href="https://timesdelphic.com/category/elections/">Elections</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31433"><a href="https://timesdelphic.com/category/features/">Features</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31434"><a href="https://timesdelphic.com/category/in-des-moines/">In Des Moines</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31435"><a href="https://timesdelphic.com/category/news/">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31436"><a href="https://timesdelphic.com/category/weekinphotos/">This week in photos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31437"><a href="https://timesdelphic.com/category/top-news/">Top News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31438"><a href="https://timesdelphic.com/category/top-stories/">Top Stories</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31439"><a href="https://timesdelphic.com/category/uncategorized/">Uncategorized</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31440"><a href="https://timesdelphic.com/category/video/">Video</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31441"><a href="https://timesdelphic.com/category/sports/">Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31442"><a href="https://timesdelphic.com/category/securityreports/">Security Reports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31443"><a href="https://timesdelphic.com/category/relays-edition/">Relays Edition</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31445"><a href="https://timesdelphic.com/category/poll/">Poll</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31444"><a href="https://timesdelphic.com/category/podcasts/">Podcasts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31446"><a href="https://timesdelphic.com/category/online/">Online Exclusives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31447"><a href="https://timesdelphic.com/category/opinion/">Opinion</a></li>
</ul>
</li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://www.facebook.com/jegtheme/" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/jegtheme" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="#" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a><a href="#" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>Copyright 2015 Fuel Themes. All RIGHTS RESERVED.</p>
</div>    </div>
</div>    </div>
</div><!-- Login Popup Content -->
<div id="jeg_loginform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="login" method="post" accept-charset="utf-8">
            <h3>Welcome Back!</h3>            <p>Login to your account below</p>

            <!-- Form Messages -->
            <div class="form-message"></div>
            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
            <p class="input_field">
                <input type="password" name="password" placeholder="Password" value="">
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
			<p class="submit">
                <input type="hidden" name="action" value="login_handler">
                <input type="hidden" name="jnews_nonce" value="78f65bf362">
                <input type="submit" name="jeg_login_button" class="button" value="Log In" data-process="Processing . . ." data-string="Log In">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_forgotform" class="jeg_popuplink forgot">Forgotten Password?</a>
                            </div>
        </form>
    </div>
</div>

<!-- Register Popup Content -->
<div id="jeg_registerform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="register" method="post" accept-charset="utf-8">
            <h3>Create New Account!</h3>            <p>Fill the forms bellow to register</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="email" placeholder="Your email" value="">
            </p>
            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
            <p class="submit">
                <input type="hidden" name="action" value="register_handler">
                <input type="hidden" name="jnews_nonce" value="78f65bf362">
                <input type="submit" name="jeg_login_button" class="button" value="Sign Up" data-process="Processing . . ." data-string="Sign Up">
            </p>
                        <div class="bottom_links clearfix">
                <span>All fields are required.</span>
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div>

<!-- Register Popup Content -->
<div id="jeg_forgotform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="forgot" method="post" accept-charset="utf-8">
            <h3>Retrieve your password</h3>
            <p>Please enter your username or email address to reset your password.</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="user_login" placeholder="Your email or username" value="">
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
            <p class="submit">
                <input type="hidden" name="action" value="forget_password_handler">
                <input type="hidden" name="jnews_nonce" value="78f65bf362">
                <input type="submit" name="jeg_login_button" class="button" value="Reset Password" data-process="Processing . . ." data-string="Reset Password">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div><script type="text/javascript">var jfla = ["view_counter"]</script><div id="jeg_playlist" class="jeg_popup create_playlist mfp-with-anim mfp-hide">
	<div class="jeg_popupform jeg_popupform_playlist">
		<form action="#" method="post" accept-charset="utf-8">
			<h3>Add New Playlist</h3>

			<!-- Form Messages -->
			<div class="form-message"></div>

			<div class="form-group">
				<p class="input_field">
					<input type="text" name="title"
						   placeholder="Playlist Name"
						   value="">
				</p>
				<p class="input_field">
					<select name='visibility'><option disabled selected='selected' value=''>- Select Visibility -</option><option value='public' >Public</option><option value='private' >Private</option></select>				</p>
				<!-- submit button -->
				<div class="submit">
					<input type="hidden" name="type" value="create_playlist">
					<input type="hidden" name="action" value="playlist_handler">
					<input type="hidden" name="post_id" value="">
					<input type="hidden" name="jnews-playlist-nonce"
						   value="5bff0d8827">
					<input type="submit" name="jeg_save_button" class="button"
						   value="Save"
						   data-process="Processing . . ."
						   data-string="Save">
				</div>
			</div>


		</form>
	</div>
</div>

<div id="notification_action_renderer" class="jeg_popup_container">
	<div id="paper_toast">
		<span id="label"></span>
	</div>
</div>
<div class="jeg_read_progress_wrapper"></div><script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id='jquery-ui-mouse-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.12.1' id='jquery-ui-sortable-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/jnews-frontend-submit/assets/js/frontend.js?ver=7.0.1' id='jnews-frontend-submit-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.7' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/dist/hooks.min.js?ver=a7edae857aab69d69fa10d5aef23a5de' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/dist/i18n.min.js?ver=5f1269854226b4dd90450db411a12b79' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.19' id='lodash-js'></script>
<script type='text/javascript' id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/dist/url.min.js?ver=9e623834b7667b522230408f099fc05f' id='wp-url-js'></script>
<script type='text/javascript' id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/dist/api-fetch.min.js?ver=134e23b5f88ba06a093f9f92520a98df' id='wp-api-fetch-js'></script>
<script type='text/javascript' id='wp-api-fetch-js-after'>
wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://timesdelphic.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "f0a6d1a28d" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://timesdelphic.com/wp-admin/admin-ajax.php?action=rest-nonce";
</script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.4' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/ditty-news-ticker/inc/static/js/swiped-events.min.js?ver=1.1.4' id='swiped-events-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.12.1' id='jquery-effects-core-js'></script>
<script type='text/javascript' id='ditty-news-ticker-js-extra'>
/* <![CDATA[ */
var mtphr_dnt_vars = {"is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/ditty-news-ticker/inc/static/js/ditty-news-ticker.min.js?ver=1613713087' id='ditty-news-ticker-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/jnews-video/assets/js/supposition.js?ver=7.0.2' id='supposition-js'></script>
<script type='text/javascript' id='jnews-video-js-extra'>
/* <![CDATA[ */
var jnewsvideo = {"user_playlist":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/jnews-video/assets/js/plugin.js?ver=7.0.2' id='jnews-video-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/aesop-story-engine/public/assets/js/ai-core.min.js?ver=2.2.10' id='ai-core-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/aesop-story-engine/public/assets/js/swipebox.min.js?ver=2.2.10' id='ai-swipebox-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.8.4' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.8.4' id='wp-mediaelement-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js'></script>
<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"34193","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"timesdelphic.com"};
/* ]]> */
</script>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=7.0.4' id='jnews-frontend-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://timesdelphic.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=7.0.4' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' src='https://timesdelphic.com/wp-content/plugins/jnews-like/assets/js/plugin.js?ver=7.0.1' id='jnews-like-js'></script>
<script type='text/javascript' src='https://timesdelphic.com/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"\"Meet the candidates running for At-Large, Equity and Inclusion and Academic Senators\"","published":"2022-04-11 18:47:41","updated":"2022-04-13 18:19:04"}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/timesdelphic.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/timesdelphic.com\/category\/top-news\/","name":"Top News"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/timesdelphic.com","name":"Home"}},{"@type":"ListItem","position":4,"item":{"@id":"https:\/\/timesdelphic.com\/category\/top-news\/","name":"Top News"}}]}</script>
<span style="display:block; font-size:0;height:0;">Bodybuilder is fighting for his life after taking dirty steroids <a href="http://uk-roids.com/oral-steroids/763-buy-FEMARA-2.5-in-uk" title="femara uk">femara uk</a> trump's "operation warp speed" for mass vaxxing. "big bucks for big pharma" - global research</span>

</body>
</html>

<!-- Page generated by LiteSpeed Cache 3.6.2 on 2022-04-13 13:28:17 -->